Author Topic: Login Custom Keyboard Layout  (Read 367 times)

Offline koken

  • New Friend
  • *
  • Posts: 7
  • Eureka! It's PCLinuxOS!
Login Custom Keyboard Layout
« on: January 14, 2020, 12:03:31 PM »
I use Colemak Keyboard Layout, which works well in this fresh Mate install.

However, when I login I'm forced to use the default keyboard layout.

Is there any way to select the layout on the login screen?

Thanks.
Logged

Offline Tex

  • Administrator
  • Super Villain
  • **********
  • Posts: 21973
  • Space City, Tx
Re: Login Custom Keyboard Layout
« Reply #1 on: January 14, 2020, 02:02:59 PM »
I use Colemak Keyboard Layout, which works well in this fresh Mate install.

However, when I login I'm forced to use the default keyboard layout.

Is there any way to select the layout on the login screen?

Thanks.

I've never heard of the Colemak Keyboard Layout but I found it called en-latin9 in PCLinuxOS.

[root@localhost tex]# locate en-latin9
/usr/lib/kbd/keymaps/i386/colemak/en-latin9.map.gz

I'm not sure how to change it systemwide so it works at the login screen yet.

Logged

Offline mutse

  • Hero Member
  • ********
  • Posts: 642
  • Doet wel, ziet niet om ... al doende leren
Re: Login Custom Keyboard Layout
« Reply #2 on: January 14, 2020, 05:12:53 PM »
@ koken,

Quote
I use Colemak Keyboard Layout, which works well in this fresh Mate install.
However, when I login I'm forced to use the default keyboard layout.
Is there any way to select the layout on the login screen?

--- your keyboard (Colemak) ???



You can also solve this as follows if it had not happened at the start of the installation:

PCLinuxOS-64- Maté:

System -> Settings center -> Equipment -> Keyboard



and then:
Layouts -> Click on Add
--> Choose a format: By country -> Country = United States and -> Variants = English + English (Colemak)


 
---> Then click on add.

** --- Hopefully, that method is the solution for your question.  ???

--- Now you should be able to enter your login details automatically and without problem, with the correct keyboard setting ...

After the keyboard setting has been made, it would be best to restart the system so that the settings are properly placed within the operating system (this is also the case when a major update has been performed and a kernel version has also been upgraded).
Starting the operating system can possibly take a little longer ... be patient ...  :)

Good luck.
Best regards.,
mutse.
Logged
*-PCLOS64-Maté - kernel: the latest and newest ... 5.4.xx* & -PCLOS64-Trinity - Kernel: the latest and newest ... 5.4.xx*

Offline Tex

  • Administrator
  • Super Villain
  • **********
  • Posts: 21973
  • Space City, Tx
Re: Login Custom Keyboard Layout
« Reply #3 on: January 15, 2020, 06:36:21 AM »
setxkbmap us -variant colemak changes the layout but I don't know where you would put it so it works at the gdm login screen. Maybe set for autologin and skip the gdm login?


Logged

Offline koken

  • New Friend
  • *
  • Posts: 7
  • Eureka! It's PCLinuxOS!
Re: Login Custom Keyboard Layout
« Reply #4 on: January 16, 2020, 12:00:18 PM »
Hello again,

Thanks for all your suggestions, however the default keyboard layout is still used for login details.

I tried setting it up as mutse suggested, and Colemak works after desktop displays, but not for logins. I even tried deleting the "English (US)" entry hoping it would work with ONLY the Colemak entry available, but that didn't work.

This is not a big deal. I  just thought I would inquire about it, being what I'm used to coming from Ubuntu.

Thanks.

Logged

Offline mutse

  • Hero Member
  • ********
  • Posts: 642
  • Doet wel, ziet niet om ... al doende leren
Re: Login Custom Keyboard Layout
« Reply #5 on: January 16, 2020, 12:38:12 PM »
@ koken,

Do you sometimes use Two keyboards? (or am I misunderstanding this?)
Remove the standard keyboard ...
And, use the colemak keyboard ...

Or ... is it a screen keyboard that you use?
Or ... also tell us which configuration you have set, which operating system, laptop or desktop ???

Open a terminal and enter the following command:

Code: [Select]
inxi -Fxz
* post the output of the terminal here in your message between 'code tags'
so: select all - copy ...
(--- can be found above the message window as # - then square brackets with 'code' appear and between the square brackets a cursor blinks | ... click 4x on the space bar - those brackets are a bit different) and now 'paste' your output into your message.

Message us what happens, what works / what doesn't work?

Best regards.,
mutse.

#  = 'code-tags'  =   [code]|[code]
Logged
*-PCLOS64-Maté - kernel: the latest and newest ... 5.4.xx* & -PCLOS64-Trinity - Kernel: the latest and newest ... 5.4.xx*

Offline koken

  • New Friend
  • *
  • Posts: 7
  • Eureka! It's PCLinuxOS!
Re: Login Custom Keyboard Layout
« Reply #6 on: January 16, 2020, 01:09:27 PM »
I am using only one physical keyboard, with the US Colemak layout.

Code: [Select]
System:
  Host: localhost.localdomain Kernel: 5.4.3-pclos1 x86_64 bits: 64
  compiler: gcc v: 9.2.0 Desktop: MATE 1.22.2 Distro: PCLinuxOS 2020
Machine:
  Type: Desktop System: Hewlett-Packard product: HP Pavilion P6000 Series
  v: N/A serial: <filter>
  Mobo: FOXCONN model: 2AB1 v: 1.00 serial: <filter>
  BIOS: American Megatrends v: 6.06 date: 03/22/2011
CPU:
  Topology: Quad Core model: AMD Phenom II X4 840T bits: 64 type: MCP
  arch: K10 L2 cache: 2048 KiB
  flags: lm nx pae sse sse2 sse3 sse4a svm bogomips: 23142
  Speed: 798 MHz min/max: 800/2900 MHz Core speeds (MHz): 1: 798 2: 798
  3: 798 4: 798
Graphics:
  Device-1: AMD RS880 [Radeon HD 4200] vendor: Hewlett-Packard
  driver: radeon v: kernel bus ID: 01:05.0
  Display: server: X.Org 1.20.7 driver: ati,radeon,v4l
  resolution: 1920x1080~60Hz
  OpenGL: renderer: AMD RS880 (DRM 2.50.0 / 5.4.3-pclos1 LLVM 8.0.1)
  v: 3.3 Mesa 19.3.2 direct render: Yes
Audio:
  Device-1: AMD SBx00 Azalia vendor: Hewlett-Packard driver: snd_hda_intel
  v: kernel bus ID: 00:14.2
  Sound Server: ALSA v: k5.4.3-pclos1
Network:
  Device-1: Ralink RT3090 Wireless 802.11n 1T/1R PCIe vendor: Lite-On
  driver: rt2800pci v: 2.3.0 port: d000 bus ID: 02:00.0
  IF: wlan0 state: down mac: <filter>
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet
  vendor: Hewlett-Packard Pavilion p6774 driver: r8169 v: kernel port: e800
  bus ID: 03:00.0
  IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 1.83 TiB used: 6.83 GiB (0.4%)
  ID-1: /dev/sda vendor: Western Digital model: WD20EZRX-00D8PB0
  size: 1.82 TiB
  ID-2: /dev/sdb type: USB vendor: Kingston model: DataTraveler 2.0
  size: 14.54 GiB
Partition:
  ID-1: / size: 1.34 TiB used: 6.83 GiB (0.5%) fs: ext4 dev: /dev/sda3
  ID-2: swap-1 size: 5.59 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda5
Sensors:
  System Temperatures: cpu: 27.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 200 Uptime: 1h 00m Memory: 5.57 GiB used: 726.5 MiB (12.7%)
  Init: SysVinit runlevel: 5 Compilers: gcc: 9.2.0 Shell: bash v: 4.4.23
  inxi: 3.0.37

Thanks.
Logged

Offline Tex

  • Administrator
  • Super Villain
  • **********
  • Posts: 21973
  • Space City, Tx
Re: Login Custom Keyboard Layout
« Reply #7 on: January 16, 2020, 01:15:30 PM »
@mutse

He wants the keyboard layout to be set to that colemak thingy before he gets to the gdm login screen.

Logged

Offline koken

  • New Friend
  • *
  • Posts: 7
  • Eureka! It's PCLinuxOS!
Re: Login Custom Keyboard Layout
« Reply #8 on: January 16, 2020, 01:22:32 PM »
Also, I found the GDM Login Setup, but as far as I can tell it doesn't provide a way to specify keyboard layout.
Logged

Offline mutse

  • Hero Member
  • ********
  • Posts: 642
  • Doet wel, ziet niet om ... al doende leren
Re: Login Custom Keyboard Layout
« Reply #9 on: January 16, 2020, 02:36:52 PM »
@ koken,

Quote
Also, I found the GDM Login Setup, but as far as I can tell it doesn't provide a way to specify keyboard layout.

You're right, I don't think it's there either ???
Still strange ... you can set it up at System> Settings Center> Equipment> Keyboard ... ???





???



*** ---> I have seen, in your system specs, that you are still using kernel 5.4.3. Update your system once (via Synaptic) and then restart the computer.
After restarting you will get a boot sequence - choose the newest kernel = 5.4.11 (with arrow keys up) and <Enter> --- the system will now continue - but ... have a little patience (everything has to be placed properly, the kernel set ...) --- then you can log in.
---------------------------------------------------------------------------------------------------------------------------------

@ Tex,

Quote
@mutse

He wants the keyboard layout to be set to that colemak thingy before he gets to the gdm login screen.

--> I understand that ... but if that doesn't work, how is it possible ???
Command ???


** --
[root@localhost tex]# locate en-latin9
/usr/lib/kbd/keymaps/i386/colemak/en-latin9.map.gz

???  Could that be with you, already offered possibility ? (as indicated above)

---> Or ... which way should koken then follow ???
Logged
*-PCLOS64-Maté - kernel: the latest and newest ... 5.4.xx* & -PCLOS64-Trinity - Kernel: the latest and newest ... 5.4.xx*

Offline Tex

  • Administrator
  • Super Villain
  • **********
  • Posts: 21973
  • Space City, Tx
Re: Login Custom Keyboard Layout
« Reply #10 on: January 16, 2020, 02:49:54 PM »
I don't know yet. I never heard of colemak before a couple of days ago and I don't know a soul who uses it in a qwerty keyboard world.

Logged

Offline mutse

  • Hero Member
  • ********
  • Posts: 642
  • Doet wel, ziet niet om ... al doende leren
Re: Login Custom Keyboard Layout
« Reply #11 on: January 16, 2020, 02:54:16 PM »
@ Tex,

It is not a qwerty keyboard layout ....

It's a .... (don't fall over ...  :D  ): QWFPGJLUY keyboard layout ....



Maybe koken should still choose from the DVORAK keyboard layout (see first sentence in the image) ???
Logged
*-PCLOS64-Maté - kernel: the latest and newest ... 5.4.xx* & -PCLOS64-Trinity - Kernel: the latest and newest ... 5.4.xx*

Offline Tex

  • Administrator
  • Super Villain
  • **********
  • Posts: 21973
  • Space City, Tx
Re: Login Custom Keyboard Layout
« Reply #12 on: January 16, 2020, 02:59:30 PM »
Maybe he could use a QWERTY keyboard like the rest of us too. There is always that one guy... LOL J/K

[tex@localhost ~]$ setxkbmap us colemak
Logged

Offline mutse

  • Hero Member
  • ********
  • Posts: 642
  • Doet wel, ziet niet om ... al doende leren
Re: Login Custom Keyboard Layout
« Reply #13 on: January 16, 2020, 03:06:11 PM »

Quote
[tex@localhost ~]$ setxkbmap us colemak
Where can this be found and how do you set it up? 
Help me with that (because this also interests me).
With thanks.

mutse.
Logged
*-PCLOS64-Maté - kernel: the latest and newest ... 5.4.xx* & -PCLOS64-Trinity - Kernel: the latest and newest ... 5.4.xx*

Offline koken

  • New Friend
  • *
  • Posts: 7
  • Eureka! It's PCLinuxOS!
Re: Login Custom Keyboard Layout
« Reply #14 on: January 16, 2020, 03:09:55 PM »
I tried setxkbmap us colemak. Then rebooted. No change. Login still using usual qwerty keyboard while Desktop and applications use Colemak.

I actually used Dvorak for a while. Then went back to standard keyboard. Then switched again to Colemak. Colemak is easier to learn than Dvorak.

It's best to make up your mind and stick to one or the other.
Logged