Author Topic: Setting locale  (Read 236 times)

Offline DavidMcCann

  • New Friend
  • *
  • Posts: 9
  • Eureka! It's PCLinuxOS!
Setting locale
« on: January 14, 2020, 10:16:38 AM »
Is there a preferred method of setting the locale globally? The bash command update-locale isn't present and the file /etc/locale.conf only lists LANGUAGE. I don't want to fiddle with solutions which may fail or cause problems if there's a standard way to do it.
Logged

Offline tbschommer

  • PCLinuxOS Tester
  • Hero Member
  • *******
  • Posts: 6295
  • In Tex we trust
Re: Setting locale
« Reply #1 on: January 14, 2020, 10:39:00 AM »
The script addlocale (to be found under the same name in the repository) does this, which also includes downloading language-specific extensions for the desktop environment, Firefox, Thunderbird, Libreoffice, and more.

You should find it in the menu in the Software Center section.

Logged
Please donate or become a patron on Patreon



In memory of Joble, Tara-Rain-9.5ß, Sproggy

Offline DavidMcCann

  • New Friend
  • *
  • Posts: 9
  • Eureka! It's PCLinuxOS!
Re: Setting locale
« Reply #2 on: January 14, 2020, 12:13:31 PM »
Thanks for the quick reply. Unfortunately addlocale, which was already installed, did nothing. Fiddling is obviously in order.  :(

PS
Well, it seems that altering /etc/locale.conf has no effect — something else is over-riding it. But setting both LC_ALL and LANG in .bashrc does work.

In my years at Linux Questions, I've usually ended up answering my own questions — it seems that the tradition is to continue!
Logged

Offline Tex

  • Administrator
  • Super Villain
  • **********
  • Posts: 21973
  • Space City, Tx
Re: Setting locale
« Reply #3 on: January 14, 2020, 12:32:05 PM »
You ran addlocale from the menu and selected your desired language? What desktop are you using because I just ran addlocale and converted my KDE plasma desktop to German. Wunderbar!

Logged

Offline mutse

  • Hero Member
  • ********
  • Posts: 642
  • Doet wel, ziet niet om ... al doende leren
Re: Setting locale
« Reply #4 on: January 14, 2020, 01:17:49 PM »
@ DavidMcCann,

No panic is required, just take a deep breath ...
It goes like this - and there are two ways to realize (do) that are actually very simple ...

1) For PCLOS Mate:

Menu -> Software Center -> Localization manager

Attention !! your operating system must be fully updated !!
Otherwise it will not work - you will see why ...

2) Other way: For all De's (Xfce, Trinity, KDE, MATE, ...) you can also use the terminal for that ...

Open the terminal:

Tap:
Code: [Select]
su    
<Enter>

password: ......       (Root password.) 
<Enter>

Typ in: 
Code: [Select]
apt-get update    
<Enter>

Tap in:
Code: [Select]
addlocale <Enter>
 
- a window with explanation will appear...



- click Oké.

Then go through the entire procedure whereby you have to enter the language (your language) --- you have to keep your attention !!
After the procedure has been successfully completed, the system will restart ...

* Good luck!

Do you have any questions ... you ask them here, we are happy to help you ...

mutse.

Quote
Is there a preferred method of setting the locale globally? The bash command update-locale isn't present and the file /etc/locale.conf only lists LANGUAGE. I don't want to fiddle with solutions which may fail or cause problems if there's a standard way to do it.

Quote
Is there a preferred method of setting the locale globally?

What do you mean ...???
You can set the language of a country anywhere in the world via addlocale.
It is even possible to set multiple languages in LibreOffice ...
By taking a good look at your system, trying something out, you sometimes find out how it all works.
It is even more fun, and especially when you can't figure out or get stuck, that you can count on this excellent and friendly PCLinuxOS Forum.
Logged
*-PCLOS64-Maté - kernel: the latest and newest ... 5.4.xx* & -PCLOS64-Trinity - Kernel: the latest and newest ... 5.4.xx*

Offline DavidMcCann

  • New Friend
  • *
  • Posts: 9
  • Eureka! It's PCLinuxOS!
Re: Setting locale
« Reply #5 on: January 17, 2020, 11:37:49 AM »
I fixed it by editing ~/.bash.rc.

Of course the initial problem was that the installation gave me a US locale, despite my having a GB keyboard and timezone. All the programs adopted the locale and had to be reconfigured manually, even after setting the new locale. I still haven't got round to doing something about the date in Thunar.

I never panic — I've been using Linux since before Fedora split from RHEL — but I do get a bit testy sometimes!
Logged

Offline kjpetrie

  • PCLinuxOS Tester
  • Hero Member
  • *******
  • Posts: 9481
  • Cogito ergo qui est?
    • K J Petrie
Re: Setting locale
« Reply #6 on: January 17, 2020, 12:09:35 PM »
Sounds as if you did it the hard way. When you installed you should have been asked for your keyboard layout on the first question after X starts in the live session. That is then what will be used for installation. Addlocale should set everything up to your chosen locale. I use en_GB myself and it's all straightforward.

Time zone setting is done in PCC (Configure your Computer).

Of course, you can do it all by editing files if you prefer and you know how to edit what.
Logged
KJP
-----------------------------------------------------------
PClos64 2013 (KDE5) on AMD FX 8350 on GA-970A-DS3P (Rev 2.0), 24GB RAM, Asus EN210 (Nvidia) GPU, Maxtor STM325031, 3 SSDs, Amilo LSL 3220T monitor. Also Acer 5810TG.

https://www.kjpetrie.co.uk/