Author Topic: Open As Administrator crash (SOLVED)  (Read 328 times)

Offline Sal

  • Hero Member
  • ********
  • Posts: 4814
  • GOD BLESS RETIREMENT
Open As Administrator crash (SOLVED)
« on: December 07, 2019, 10:55:06 PM »
Lately on my Mate workstation when attempting to use the "open as administrator" right click option in any of the file/folder menus a second window with attempt to open and then immediately crash?  I can su to root in a terminal without issue so it's strictly a gui problem. This is simply a issue with this install as I maintain a couple other similar installs that do not exhibit the problem?
I'm kind of stuck as to how/where to begin looking for the problem?  Anyone have any ideas?
Logged
Custom Music Server Tower,  Mod'ed PCLinuxOS OS,  MATE 64 Desktop
Strawberry Media Player, Bit Perfect Server Configuration
Emotiva Stealth DC-1 USB DAC-Headphone-PreAmp,
Marantz AV7703 Pre/Pro, 5 Adcom GFA5X5 II amps, HSU Research/Klispch 5.2.4 System w2 STF-2 subs
Sennheiser HD 650 Headphones

Offline onkelho

  • PCLinuxOS Tester
  • Hero Member
  • *******
  • Posts: 1100
  • from2007toSAMtoULtoQuá-ít
    • Quait
Re: Open As Administrator crash
« Reply #1 on: December 08, 2019, 01:43:48 AM »
Synaptic -> search "gksu" and "xdg"  what is installed? and what is not installed?
and please check if you logged in as root the content of /root/... Bookmarks like Pictures, Documents,...
the file is in /root/.config/gtk3/bookmarks, open it with pluma and read the content:
if there is a other username such root then edit/correct it, safe, logout....
Logged
GigaByte-870SB-PhenomII-X4 955, Asus EHA5770, 16GB-RAM
shared SRPMS+RPMS to pclos hosted on:
https://www.qua-it.org/XFCE/repo/SRPMS.quait/srpms.php
drivers that not delivered in the official kernel,
search on https://qua-it.org/XFCE/repo/apt/quait/2020/drivers.php

Offline parnote

  • PCLinuxOS Tester
  • Hero Member
  • *******
  • Posts: 6034
  • PCLinuxOS Magazine Editor
    • The PCLinuxOS Magazine
Re: Open As Administrator crash
« Reply #2 on: December 08, 2019, 07:59:19 AM »
I thought gksu had been deprecated and was no longer being developed/updated?? I thought that gksu had been replaced by some polkit "solution" that is as obscure as mud (try finding documentation on that one ... it's quite obscure)??
Logged
PCLinuxOS Magazine Chief Editor

Linux Registered User #485009

In a world without walls, who needs Windows?

PCLinuxOS Wiki: Contribute tips/tricks/how-to's!

Offline Sal

  • Hero Member
  • ********
  • Posts: 4814
  • GOD BLESS RETIREMENT
Re: Open As Administrator crash
« Reply #3 on: December 08, 2019, 11:50:07 AM »
Synaptic -> search "gksu" and "xdg"  what is installed? and what is not installed?
and please check if you logged in as root the content of /root/... Bookmarks like Pictures, Documents,...
the file is in /root/.config/gtk3/bookmarks, open it with pluma and read the content:
if there is a other username such root then edit/correct it, safe, logout....
gksu  and  lib64gksu2.0_0  are installed,  xdg returns the below.



Contents of /root/.config/gtk3/bookmarks  below.  Nothing wrong I can see.



Logged
Custom Music Server Tower,  Mod'ed PCLinuxOS OS,  MATE 64 Desktop
Strawberry Media Player, Bit Perfect Server Configuration
Emotiva Stealth DC-1 USB DAC-Headphone-PreAmp,
Marantz AV7703 Pre/Pro, 5 Adcom GFA5X5 II amps, HSU Research/Klispch 5.2.4 System w2 STF-2 subs
Sennheiser HD 650 Headphones

Offline Sal

  • Hero Member
  • ********
  • Posts: 4814
  • GOD BLESS RETIREMENT
Re: Open As Administrator crash
« Reply #4 on: December 12, 2019, 03:00:01 PM »
Still hoping for some ideas to fix this issue. No problems opening applications that require root access such as Synaptic or GSmart. Only when attempting to access a file in Caja with "Open As Administrator". The root password dialog box appears, I enter the password, then I get a flash of what looks to be a new window opening and it instantly crashes.   :(
TIA
Logged
Custom Music Server Tower,  Mod'ed PCLinuxOS OS,  MATE 64 Desktop
Strawberry Media Player, Bit Perfect Server Configuration
Emotiva Stealth DC-1 USB DAC-Headphone-PreAmp,
Marantz AV7703 Pre/Pro, 5 Adcom GFA5X5 II amps, HSU Research/Klispch 5.2.4 System w2 STF-2 subs
Sennheiser HD 650 Headphones

Offline Tex

  • Administrator
  • Super Villain
  • **********
  • Posts: 21971
  • Space City, Tx
Re: Open As Administrator crash
« Reply #5 on: December 12, 2019, 07:55:02 PM »
Maybe reset your mate desktop configuration files? Logout and back in again.

[tex@localhost ~]$ rm -f ~/.config/dconf/user
[tex@localhost ~]$ rm -rf ~/.config/caja
Logged

Offline Sal

  • Hero Member
  • ********
  • Posts: 4814
  • GOD BLESS RETIREMENT
Re: Open As Administrator crash
« Reply #6 on: December 12, 2019, 09:02:34 PM »
No joy there, but thanks anyway.
Logged
Custom Music Server Tower,  Mod'ed PCLinuxOS OS,  MATE 64 Desktop
Strawberry Media Player, Bit Perfect Server Configuration
Emotiva Stealth DC-1 USB DAC-Headphone-PreAmp,
Marantz AV7703 Pre/Pro, 5 Adcom GFA5X5 II amps, HSU Research/Klispch 5.2.4 System w2 STF-2 subs
Sennheiser HD 650 Headphones

Offline mooseman57

  • Jr. Member
  • **
  • Posts: 29
Re: Open As Administrator crash
« Reply #7 on: December 13, 2019, 06:27:32 AM »
Same issue on my copy of Mate.  If I wait a few seconds, K3B starts up.
Logged

Offline Tex

  • Administrator
  • Super Villain
  • **********
  • Posts: 21971
  • Space City, Tx
Re: Open As Administrator crash
« Reply #8 on: December 13, 2019, 06:39:39 AM »
No joy there, but thanks anyway.

I have no idea. Everything is OK on my install.
Logged

Offline mooseman57

  • Jr. Member
  • **
  • Posts: 29
Re: Open As Administrator crash
« Reply #9 on: December 13, 2019, 10:01:50 AM »
Mine got fixed by going into control panel,preferred applications,system,and resetting file manager to Caja
Logged

Offline Sal

  • Hero Member
  • ********
  • Posts: 4814
  • GOD BLESS RETIREMENT
Re: Open As Administrator crash
« Reply #10 on: December 13, 2019, 11:21:12 AM »
Mine got fixed by going into control panel,preferred applications,system,and resetting file manager to Caja
BINGO, give that man the grand prize.
I found mine set to java?  Strange but now that I think about it, it breaking may have ruffly coincided with my installing of the jre1.8 package? But this java is needed to run some java based apps.  :(
Thanks to everyone who tried to help!
Logged
Custom Music Server Tower,  Mod'ed PCLinuxOS OS,  MATE 64 Desktop
Strawberry Media Player, Bit Perfect Server Configuration
Emotiva Stealth DC-1 USB DAC-Headphone-PreAmp,
Marantz AV7703 Pre/Pro, 5 Adcom GFA5X5 II amps, HSU Research/Klispch 5.2.4 System w2 STF-2 subs
Sennheiser HD 650 Headphones