I havn't tried building yet, but I have run into one possible dependency problem; my output from addpkg when installing dependencies for the spec:
Do "apt-get update" first? [y/N]
Requires libnl-devel >= 1.1 and found libnl1-devel 1.1-1pclos2007 - Continue? [Y/n]
Requires libhal-devel >= 0.5.0 and found libhal1-devel 0.5.12-0.2pclos2007 - Continue? [Y/n]
The following 6 packages will be installed:
libnl1-devel dhcdbd libiw-devel libhal1-devel libgnome-keyring-devel libgnomeui2-devel
Are you sure? [y/N] y
Save list of files? [Y/n] y
Please enter root Password:
Please wait while packages are processed...
Running apt-get install
Reading Package Lists...
Building Dependency Tree...
Package libiw-devel is a virtual package provided by:
You should explicitly select one to install.
E: Package libiw-devel is a virtual package with multiple good providers.
..if you look through it, you will see that there are three packages that the script has questions about, with the last one actually causing an error requiring manual install. I'm going to do a little testing with the different packages, but my guess is that one of them might be part of the problem.