Author Topic: SketchUpMake 2015 on PCLOS64  (Read 3887 times)

Offline One_Beerhunter

  • Hero Member
  • ********
  • Posts: 542
SketchUpMake 2015 on PCLOS64
« on: February 22, 2015, 11:49:53 AM »
First let me make this perfectly clear, I am not an authority on either WINE or SketchUpMake. I am, on the other hand, more persistent than many... willing to devote untold hours to get something working out of an innate compulsion to never give up.

This is to the best of my recollection how I got SketchUpMake to actually work under WINE on PCLOS64:

First, open synaptic and select PlayOnLinux, the following will be installed:
PlayOnLinux
wine32.32bit
wine64
wine-gecko

Second, download SketchUpMake2015 from here
http://www.sketchup.com/download/all
download the 64bit windows version

Third, open PlayOnLinux and from the tools menu select, Manage Wine versions and add the latest version of Wine versions(amd64) currently version 1.7.37

Fourth, from PlayOnLinux select Install a program, at first you may be presented with a window that lacks the "install an unlisted program" button. If that happens close the install window and try again. Once you have located the "install an unlisted program" button click it and follow the prompts, create a new 64bit PlayOnLinux virtual drive, I labeled mine SketchUp2015

Fifth, a window will appears offering check boxes for selecting wine version, running wine config, adding windows components, check all the boxes.
At that time I could only select "system" for wine version.
In wineconfig on the applications tab I changed the windows version from "XP" to "7"
From the add components install "vcrun2010"

Sixth, browse to your downloaded file "SketchUpMake-en-x64.exe" and install

Seventh, PlayOnLinux will offer to make shortcuts to the executables, I only selected SketchUp.exe and then chose to not make any more shortcuts.

Finally, with your new shortcut to SketchUp highlighted, select configure and change the wine version in the drop down box from "system" to "1.7.37"

With your highlighted shortcut you may start the program via run or debug. Debug allows you to review the numerous error messages, one might complain about a missing mfc100u.dll, I copied that dll from the /home/"yourusername"/PlayOnLinux's virtual drives/SketchUp2015/drive_c/windows/syswow64 folder into the /home/"yourusername"/PlayOnLinux's virtual drives/SketchUp2015/drive_c/Program Files(x86)/Sketchup/SketchUp 2015 folder and the error went away.

MOVING THIS DLL HAS PROVED ITSELF TO BE THE DIFFERENCE BETWEEN SUCCESS AND FAILURE>>>Following my own advice I just installed Sketchup on my laptop after a fresh install of PCLOS64, I forgot to move the dll and was greeted by the frowning penguin program crash error message. Moved the DLL and problem solved.

I also discovered the tool tips do not display properly when you mouse over the icons, those tips can be turned off as they also appear at the bottom of the drawing window, so they are somewhat redundant.

In the end, this has been quite a trip and I still have a couple of errors in debug such as "(process:779): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed" I have no idea what that means or if it is even significant. All I can say with certainty is this: The above worked for me and I hope this helps others here. Now all I have left to do is start watching some tutorials on how to use SketchUP... LOL

PS> Almost forgot my computer specs:
PCLOS 64bit
AMD Phenom II X4 965 Pro
NVidia GTX460 with most recent proprietary drivers
4Gigs of Ram
Logged

Offline TN_Tux

  • Hero Member
  • ********
  • Posts: 679
  • Missed it by that much.
Re: SketchUpMake 2015 on PCLOS64
« Reply #1 on: February 22, 2015, 01:24:42 PM »
Well played, 1BH!   :D

A very thorough process explanation. If I had a 64 bit linux system, I would immediately incorporate this.
Logged
Dell Lattitude E6400 - Core 2 Duo 2.4GHz, 4GB Ram - NVIDIA G98M Graphics - Kernel 4.14.17-pclos1 x86_64 (64 bit) - KDE 5.42.0 - Nouveau video driver

Offline gseaman

  • PCLinuxOS Tester
  • Hero Member
  • *******
  • Posts: 4692
Re: SketchUpMake 2015 on PCLOS64
« Reply #2 on: October 09, 2015, 01:26:53 PM »
I just tried this and it works!
I don't use sketchup, but I help someone who had to switch to another distro because he could not get sketchup to work. Next time, I will use your tip. I read the tip in PCLinuxOS Magazine.

Galen
Logged